Untitled Document

Drive Rescue - the hard drive discovery and emergency tool

Drive Rescue is a data recovery tool for Windows(R) 95, 98, ME, NT and 2000 users.

What Drive Rescue can do for you:

  • Find any lost and deleted data on your hard disk even if the partition table is lost!
    Lost Data, that is the result of a system crash can also be recovered.
  • Discover important file system tables of your hard disk, including paritition table, boot record, FAT and file/directory records.

What Drive Rescue can NOT do for you:

  • Find any data on a physically damaged hard disk!

Features

Supported file systems: FAT 12/16/32
System requirements:

  • Microsoft(R) Windows(R) 95, 98, ME, NT, or 2000
  • Second hard disk is recommended for recovery

README language support: English, German, French

How much does it cost? That's the greatest! Nothing. This program is Freeware. You may and should freely distribute it to your friends.

Contact

For any question regarding Drive Rescue, you can send an email to alexander_grau@web.de. Every kind of feedback is always appreciated. It also would be nice if you send me a postcard (see README for address)!

License

This software is provided as freeware and you can use it only if you accept the following:

THIS SOFTWARE IS PROVIDED BY ALEXANDER GRAU "AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL ALEXANDER GRAU BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Drive Rescue - Copyright (C) 2000, 2001 by Alexander Grau, All rights reserved


In four steps you recover your deleted files!

Step 1: Run Drive Rescue

Step 2: Choose your drive

Step 3: Select your deleted files/directories
Step 4: Simply save them to another hard disk!

That's it!


Tutorial

How to recover my data...

  1. Files have been deleted or Windows(R)-recycle bin has been emptied

  2. Directories are lost

  3. Hard disk has been quick-formated

  4. A volume is lost, e.g. due to damaged partition table

  5. Windows(R) ist damaged and not bootable
  1. Files habe been deleted or Windows(R)-recycle bin has been emptied

    Select Drive from Object menu.

    Select drive as Logical drive which contains the deleted data.

    Look for your file from [image] Deleted.

    Select your file (for several files use CTRL or SHIFT key) and save your file to another drive by selecting Save selected directories/files to...

  2. Directories are lost

    Select Drive from Object menu.

    Select drive as Logical drive which contains the lost directories.

    Select Find lost data from Tools menu. The appearing dialog windows allows you to delimit the search (e.g. if you know the directory is situated more behind, move the track bar Start cluster to the rigtht).

    After completion of directory scan look for your directory at folder     [image] Lost. Select your file (for several files use CTRL or SHIFT key) and save your file to another drive by selecting Save selected directories/files to...

  3. Hard disk has been quick-formatted

    Proceed all steps like in 2.

    Important: to save your data choose the option "no FAT (consecutive)" since the FAT has been deleted by quick-formatting!

  4. A volume is lost, e.g. due to damaged partition table

     Select Drive from Object menu.

    Select drive as Physical drive which contains the deleted partition. Select button Find logical drive...

    The appearing dialog windows allows you to delimit the search (e.g. if you know the partition is situated more behind, move the track bar Start cluster to the rigtht).

    After the search has been started and a logical drive has been found you can Accept the found drive if the format seems to be correct. Otherwise choose Find next and the program will continue search. It is not exceptional if more drives are found than has been installed. The reason is that there are several copies of the boot sector on the hard disk (that's the unit that contains the information about a logical drive). So proceed until the right drive has been found.

    After completion of drive scan look for your drive at folder     [image] Root. Select your file (for several files use CTRL or SHIFT key) and save your file to another drive by selecting Save selected directories/files to...

  5. Windows(R) ist damaged and not bootable

    Drive Rescue requires Windows(R). Therefore use a second hard disk with Windows(R) and Drive Rescue installed. Configure this drive as master and the damaged drive as slave drive.


Introduction to the File Allocation Table (FAT)

Every disk or hard disk, that has been formatted with the FAT system is built as follows

The write process
The operating system writes system information like file size and first cluster number to the directory entry, position information to the FAT, and data itself to the data area.

The read process
(1) System information, like file name, size and first cluster number is determined from the directory entry.
(2) Further cluster numbers are found from the file allocation table (FAT) and read from the corresponding clusters in the data area.

The file system exists from a number of special areas of the disk set aside for organization when the disk is formatted: the master boot record, the partition table, the boot record, the file allocation table (from which the FAT system takes its name), and the root directory. At a low level, disk are organized into 512 byte groups called sectors. The FAT system allocates space for files using a unit called a cluster, made up of an integral number of sectors.

A boot record is a sector which contains code that can is executed by the computer. The master boot record is the first boot record that the computer executes when it accesses the hard disk. Additonally a boot record contains important information about the FAT file system, e.g. the cluster size and the positions of the file allocation table, data area and the root directory.

The file allocation table (FAT), located behind the boot record is a database that associates clusters of disk space with files. It has one entry (each 12,16 or 32 bits) for each cluster. Because the first two entries are reserved for the file system, the third entry and those following are assigned to clusters of disk space (data area). Files saved in the data area are not necessarily stored successively and therefore the operating system has to know where a complete file is located in the data area. That is the task of the FAT. For any cluster that is used by a file but is not the file's last cluster, the FAT entry contains the number of the next cluster used by the file. When a program asks the operating system (OS) to provide the content of a file, the OS has to read the first cluster of a file. It then looks at the corresponding first cluster entry in the FAT and knows the next cluster number where the file continues. Now it reads the associated cluster in the data area. After this cluster is also totally read the OS repeats this method until the whole file is read. This way of organizing a file is called the FAT chain.

FAT entries may contain a few special values to indicate that

  • the cluster is free-that is, not in use by a file (0000H for FAT16)
  • the cluster contains one or more sectors that are physically damaged and should not be used (FFF7H for FAT16)
  • and the cluster is the final cluster in a file (FFF8-FFFFH for FAT16), also called End Of File (EOF)

But from where does the OS know what files are on the disk and where to find the first cluster of that files? That is the reason for the directory entries which are also stored in the data area. Each directory entry has a size of 32 byte and includes information about the file or directory name, size, first cluster number and its attributes.


Data-loss

Data-loss results from the fact that the direcotry entries and/or the FAT are deleted or contain incorrect information. The operating system works at an access to files as follows: Read data from directory entry -> Read data in the data area-> Read informationen from the FAT and repeat from next to last step until file is completely read. If the directory enties and/or the FAT are incorrect or deleted, the operating system can not read however any longer, although this is still in the data area. This is the reason why users think, their data is lost - in reality it is still available. Finding this data can be very complex however somtimes, since the entire drive has to be examined.

Data-loss of the content itself
Data is completely lost, if the content is damaged or overwritten (the file was not lost due to incorrect information in the FAT or the directory entries).

This could have the following causes:

  1. The Hard disk/floppy disk is physically damaged
  2. Viruses or something else destroyed the data
  3. Writing other files to the disk has led to it, that some or all clusters of a file were changed. In this case only a part of the data can be recoverd.


Deleted data

Deleted data is not really lost but is simply ignored by the operating system. If the user deletes a file (hereby it is not meant shifting it into the Windows waste-paper basket), the first letter of a directory entry is provided with a special character (it is E5 hexadecimal - i.e. 229 decimal). In addition, the information about the order of the clusters has been removed by the erasure however. That plays no role in this respect, if the file was not fragmented (i.e. all clusters of the file were stored successively). With fragmented drives (this originates through frequent erasure and storing) the chances for recovering looks relatively badly. If however the file is visible under the folder 'Deleted' in Drive Rescue, you can try to recover it, and Drive Rescue will assume the file was is not fragmented.


Effective precaution-measures

You can increase the chances to recover data, if you consider some points.

  1. Do not store important files in the root directory.
    Files, which are stored in the root directory, are sensitive to a loss by quick formatting, because file entries are set-aside in the root.
    Avoid to store to store files directly in the root since the file disappears, if the directory entry is damaged    . In an emergency, one can recover data very quickly if it is in a sub-directory.

  2. Defragment the hard drive regularly
    Data is stored in successive clusters, if sufficient connected free storage location is available. Repeated deletion and write operations fragment the drive.

    An example:

    (1) (2) (3) (4) (5) (6) (7) (8) - should represent 8 small files

     (1) (2) (3) (4) (5) (6) (7) (8) - now files (2), (4), (7) and (8) were deleted

    (1) (9) (3) (9) (5) (6) (9) (9) - disk is fragmented if a larger file is stored

    If data is deleted from the disk, new data can take the free place. If the new data is larger than the old one however, the data is net set aside in coherent range, but in fragments.
    When reading fragmented data the head of the hard disk has to 'jump' (i.e. the head moves to the looked track). Thus the reading and write speed is reduced.
    In order to make the read and write procedure again more efficient, it is necesscary to reorganize the fragmented disk. After defragmentation, the data is in sequential order and then look in such a way:

    (1) (9) (9) (9) (9) (3) (5) (6) - after the drive is defragmented

    A usually fragmented disk will degree the efficiency of a data-rescue, if e.g. the FAT is overwritten by a quick format or a virus. Then it is necessary to analyse exactly, how a file scattered over the disk lies. If however connected data is present, a data-rescue is very quickly possible on the basis of the information about its position and size.

    Important: A non-fragmented disk will increase you rate of recovery because the complete data is stored at the beginning of the first cluster of a file.

  3. Do not store important data on drives with small capacity
    The probability of the recover is lower, the smaller the disk capacity is. Important data should be saved on a free drive. The smaller the capacity is, the higher the risk of fragmentation is.

  4. Defragment your floppy disk, after data is stored on it
    Disks are fragmented with very high probability. Therefore it is advisable with important data, to distribute the files into several directories and then defragment the floppy disk    .

  5. Do not use a drive, which you require to the data-rescue.
    Do not install recovery software on a drive that contains data for your data-rescue. Otherwise data could be overwritten and success on a data rescue becomes smaller. Avoid working with the drive and do not save any data on it. Do not use a usal program, including the Windows(R) Explorer, in order not to overwrite important deleted data.
    For the data-recovery you should use a second hard disk.


Drive Rescue - Das Festplatten Discovery- und Emergency Tool

Drive Rescue ist ein Datenrettungstool für Benutzer von Windows(R) 95, 98, ME, NT und 2000.

Was Sie mit Drive Rescue machen können:

  • Verlorene und gelöschte Daten von Ihrer Festplatte wiederherstellen - auch wenn die Partitionstabelle verloren gegangen ist!
    Verlorene Daten, entstanden durch eine Quick-Formatierung oder durch einen Systemabsturz, können ebenfalls wiederhergestellt werden.
  • Untersuchen Sie wichtige Teile des Dateisystems Ihrer Festplatte, d.h. Parititionstabelle, Boot Record, Dateizuordnungstabelle (FAT) und Dateien/Ordner eingeschlossen.

Was Sie mit Drive Rescue NICHT machen können:

  • Daten auf einer physikalisch beschädigten Festplatte finden!

Features

Unterstützte Dateisysteme: FAT 12/16/32
Systemvoraussetzungen:

  • Microsoft(R) Windows(R) 95, 98, ME, NT, oder 2000
  • Zweite Festplatte wird zum Wiederherstellen empfohlen

Unterstützte Sprachen der README-Datei: Englisch, Deutsch, Französisch

Was kostet dieses Programm? Das ist das Beste! Nichts. Diese Programm ist Freeware. Sie können und sollen dieses Programm an Ihre Freunde und Bekannte weitergeben.

Kontakt aufnehmen

Fragen, die das Programm Drive Rescue betreffen, können Sie an alexander_grau@web.de stellen. Jede Art des Feedbacks ist willkommen. Schicken Sie mir doch einfach eine Postkarte, wenn Ihnen das Programm helfen konnte (siehe README für Adresse)!

Lizenz

Diese Software wird als Freeware angeboten und Sie können sie nur benutzen, wenn Sie folgendes akzeptieren:

DER AUTOR ÜBERNIMMT KEINERLEI GARANTIEN HINSICHTLICH DES INHALTS DER SOFWARE, DER BENUTZUNGSMODALITÄTEN ODER EIGNUNG FÜR SPEZIFISCHE ANFORDERUNGEN. DER ERZEUGER HAFTET WEITERES WEDER FÜR FEHLER IN DER SOFTWARE NOCH FüR DIREKTE, INDIREKTE UND FOLGESCHÄDEN ODER GEWINNEINBUSSEN IN ZUSAMMENHANG MIT DER SOFTWAREVERWENDUNG. DIE INBETRIEBNAHME DER SOFTWARE SETZT DAS EINVERSTÄNDNIS DES BENUTZERS MIT DIESER EINSCHRÄNKUNG VORAUS.

Drive Rescue - Copyright (C) 2000, 2001 by Alexander Grau, All rights reserved


In vier Schritten stellen Sie Ihre gelöschten Dateien wieder her!

Schritt 1: Drive Rescue starten

Schritt 2: Laufwerk auswählen

Schritt 3: Wiederherzustellende Dateien/
Ordner auswählen
Schritt 4: Einfach auf einer anderen
Festplatte speichern!

Kaum zu glaube, daß es so einfach geht?


Tutorial

Wie stelle ich meine Daten wieder her...

  1. Dateien wurden gelöscht oder der Windows(R)-Papierkorb wurde entleert

  2. Verzeichnisse sind verschwunden

  3. Die Festplatte wurde mit Quick-Format formatiert

  4. Ein Laufwerk ist verschwunden, weil z.B. die Partitionstabelle ist beschädigt ist

  5. Windows(R) ist beschädigt und kann nicht mehr gestartet werden
  1. Dateien wurden gelöscht oder der Windows(R)-Papierkorb wurde entleert

    Wählen Sie Drive im Menü Object.

    Wählen Sie das Laufwerk unter Logical drive aus, welches die gelöschten Dateien enthält.

    Schauen Sie nach der Datei unter [image] Deleted.

    Markieren Sie die wiederherzustellenden Datei (markieren Sie mehrere Dateien mit STRG- bzw. SHIFT-Taste) und wählen Sie den Schaltknopf Save selected directories/files to..., um die Datei auf einem zweiten Laufwerk zu sichern.

  2. Verzeichnisse sind verschwunden

    Wählen Sie Drive im Menü Object.

    Wählen Sie das Laufwerk unter Logical drive aus, welches die verlorenen Verzeichnisse enthält.

    Wählen Sie Find lost data im Menü Tools. Im neu angezeigten Dialogfenster haben Sie die Möglichkeit, die Suche einzugrenzen (wenn Sie z.B. wissen, daß die Verzeichnisse weiter hinten liegen, schieben Sie den Regler Start cluster weiter nach hinten).

    Nachdem die Suche abgeschlossen ist, s    chauen Sie nach dem Verzeichnis unter [image] Lost. Markieren Sie die wiederherzustellenden Verzeichnisse (markieren Sie mehrere Verzeichnisse mit STRG- bzw. SHIFT-Taste) und wählen Sie den Schaltknopf "Save selected directories/files to...", um das Verzeichnis auf einem zweiten Laufwerk zu sichern.

  3. Die Festplatte wurde mit Quick-Format formatiert

    Führen Sie alle Schritte so durch, wie unter 2.
    Wichtig: wählen Sie beim Speichern Ihrer Dateien jedoch die Option "no FAT (consecutive)", da der FAT beim Quick-Formatieren gelöscht worden ist!

  4. Ein Laufwerk ist verschwunden, weil z.B. die Partitionstabelle ist beschädigt ist

     Wählen Sie Drive im Menü Object.

    Wählen Sie das Laufwerk unter Physical drive aus, welches die verlorene Partition enthält. Betätigen Sie den Schaltknopf Find logical drive...

    Im neu angezeigten Dialogfenster haben Sie die Möglichkeit, die Suche einzugrenzen (wenn Sie z.B. wissen, daß die Partition weiter hinten liegt, schieben Sie den Regler Start cluster weiter nach rechts).

    Nachdem die Suche gestartet, und ein logisches Laufwerk gefunden wurde, bestätigen Sie das gefundene Laufwerk mit Accept, wenn das Format korrekt ist. Andernfalls lassen Sie das Programm weitersuchen (Find next). Es ist nicht außergewöhnlich, wenn das Programm mehr logische Laufwerke findet, als eigentlich auf der Festplatte abgelegt sind. Das liegt daran, daß sich in der Regel mehrere Kopien des Bootsektors (das ist der Sektor, der die Informationen über ein logisches Laufwerk enthält) auf einer Festplatte befinden. Wiederholen Sie also diesen Schritt, bis das gesuchte Laufwerk gefunden wurde.

    Nachdem die Suche abgeschlossen ist, s    chauen Sie nach dem Laufwerk unter [image] Root. Markieren Sie die wiederherzustellenden Verzeichnisse (markieren Sie mehrere Verzeichnisse mit STRG- bzw. SHIFT-Taste) und wählen Sie den Schaltknopf Save selected directories/files to..., um die Verzeichnisse auf einem zweiten Laufwerk zu sichern.

  5. Windows(R) ist beschädigt und kann nicht mehr gestartet werden

    Drive Rescue benötigt Windows(R). Verwenden Sie daher ein anderes Laufwerk, auf dem Sie Windows(R) und Drive Rescue installiert haben. Dieses Laufwerk konfigurieren Sie als Startlaufwerk (Master), die beschädigte Festplatte als Slave.


Einführung in die File Allocation Table (FAT)

Jede Diskette oder Festplatte, die nach dem FAT Dateisystem formatiert wurde, ist folgendermaßen aufgebaut:

Der Datei-Schreibvorgang
Das Betriebssystem schreibt Systeminformationen,wie die Dateigröße, die erste Cluster-Nummer in den Directory-Eintrag, die Positionsinformationen in den FAT, und die Daten selbst in den Datenbereich.

Der Datei-Lesevorgang
(1) Systeminformationen, wie Dateiname, Größe und erste Cluster-Nummer werden aus dem Directory-Eintrag ermittelt
(2) Weitere Cluster-Nummern werden aus der Dateizuordnungstabelle (FAT) ausfindig gemacht und die entsprechenden Cluster im Datenbereich eingelesen

Das Dateisystem besteht aus einer Anzahl von speziellen Bereichen für die Verwaltung des Datenträgers, die erstellt werden, wenn der Datenträger formatiert wird: der Master Boot Record, die Partitionstabelle,der Boot Record, die Dateizuordnungstabelle (danach ist das FAT System benannt worden), und das Wurzelverzeichnis (Root directory). Auf unterster Ebene gesehen, sind Disketten und Festplatten eingeteilt in Gruppen von 512 Bytes, sogenannte Sektoren. Das FAT System reserviert für Dateien Speicherplatz in Form von mehreren Sektoren, Cluster gennant.

Der Boot Record ist ein Sektor, der Programmcode enthält, welcher vom Computer ausgeführt wird. Der Master Boot Record ist der erste Boot Record, den der Computer beim ersten Zugriff auf die Festplatte ausführt. Darüber hinaus enthält ein Boot Record wichtige Informationen über das FAT Dateisystem, z.B. die Clustergröße, die Positionen von Dateizuordnungstabelle (FAT), Datenbereich (data area) und dem Wurzelverzeichnis (root).

Die Dateizuordnungstabelle (FAT), die sich hinter dem Boot Record befindet stellt eine Datenbank dar, welche Cluster-Speicherplatz mit Dateien assoziiert. Sie enthält einen Eintrag (jeder 12,16 oder 32 Bits groß) für jeden Cluster. Da die ersten zwei Einträge für das Dateisystem reserviert sind, ordnet man dem dritten und den folgenden Einträgen den Cluster-Speicherplatz zu (Datenbereich, data area). Dateien, die im Datenbereich abgespeichert werden, müssen nicht unbedingt aufeinander folgende Cluster belegen und daher muß das Betriebssystem (operating system, OS) wissen, wo sich die komplette Datei im Datenbereich befindet. Das ist die Aufgabe des FAT. Für jeden Cluster, der von der Datei verwendet wird und nicht der letzte Cluster ist, enthält der FAT-Eintrag die Nummer des nächsten Cluster, welche von der Datei belegt ist. Wenn ein Programm dem Betriebssystem mitteilt, auf eine Datei zugreifen zu wollen, muß das Betriebssystem zunächst den ersten Cluster der Datei lesen. Dann schaut es in dem korrespondierenden ersten Eintrag im FAT nach, um die nächste Cluster-Nummer zu ermitteln, bei welcher die Datei fortgesetzt wird. Nun liest es den im Datenbereich assoziierten Cluster und nachdem auch dieser vollständig gelesen wurde, wiederholt das Betriebssystem diese Methode solange, bis die komplette Datei gelesen wurde. Diese Art der Organisation in Form einer Kette nennt man auch FAT-Kette (FAT chain).

FAT Einträge können ein paar spezielle Werte enthalten, um anzuzeigen, daß

  • der Cluster frei ist-also nicht von einer Datei belegt ist (0000H für FAT16)
  • der Cluster ein oder mehrere Sektoren enthält, die physikalisch beschädigt sind und nicht verwendet werden sollen (FFF7H für FAT16)
  • der Cluster der letzte einer Datei ist (FFF8-FFFFH für FAT16), auch End Of File (EOF) gennant

Aber woher weiß eigentlich das Betriebssystem, welche Dateien auf einer Festplatte sind, und wie findet es den ersten Cluster heraus? Genau das ist der die Aufgabe der Directory-Einträge (directory entries), welche ebenfalls im Datenbereich abgelegt sind. Jeder Directory-Eintrag hat eine Größe von 32 Byte und bietet folgende Informationen über eine Datei oder einen Ordner: Datei- oder Ordnername, Größe, erste Cluster-Nummer und seine Attribute.


Datenverlust

Datenverlust entsteht dadurch, daß die Directory Einträge und/oder der FAT gelöscht worden sind oder fehlerhafte Informationen enthalten. Das Betriebssystem arbeitet bei einem Zugriff auf Dateien wie folgt: Daten aus Directory Eintrag lesen-> Daten im Datenbereich lesen-> FAT Informationen lesen und vorletzten Schritt wiederholen, bis die Datei vollständig gelesen wurde. Wenn die Directory Einträge und/oder FAT Einträge fehlerhaft bzw. gelöscht worden sind, kann das Betriebssystem die Datei jedoch nicht mehr lesen, obwohl diese sich noch im Datenbereich befindet. Aus diesem Grund meinen Anwender, ihre Daten wären verloren, in Wirklichkeit sind die Daten noch erhalten. Das Auffinden der Daten kann jedoch unter Umständen sehr aufwendig sein, da der gesamte Datenträger untersucht werden muß.

Datenverlust von Dateiinhalten
Daten sind vollständig verloren, wenn der Dateiinhalt beschädigt ist (also die Datei nicht durch fehlerhafte Informationen in FAT und Dateieinträgen verloren gegangen ist).

Dies könnte folgende Ursachen haben:

  1. Die Fesplatte/Diskette ist physikalisch beschädigt
  2. Viren oder Ähnliches haben die Daten zerstört
  3. Überschreiben von anderen Dateien haben dazu geführt, daß einige oder alle Cluster einer Datei geändert wurden. In diesem Fall kann nur noch ein Teil der Daten wiederhergestellt werden.


Gelöschte Daten

Gelöschte Dateien sind nicht wirklich gelöscht, sondern werden vom Betriebssystem einfach ignoriert. Wenn der Anwender eine Datei löscht (hiermit ist nicht das Verschieben in den Windows Papierkorb gemeint), wird der erste Buchstabe eines Directory Eintrages mit einem speziellen Zeichen versehen (es ist E5 hexadezimal - d.h. 229 dezimal). Weiter ist aber auch die Information über die Anordnung der Dateicluster beim Löschen entfernt worden. Das spielt insofern keine Rolle, wenn die Datei nicht fragmentiert war (d.h. die Cluster der Datei waren alle nacheinander abgespeichert). Bei fragmentierten Festplatten (dies entsteht durch häufiges Löschen und Kopieren) sehen die Chancen für eine Wiederherstellung relativ schlecht aus. Falls Sie jedoch die Datei unter Drive Rescue im Ordner "Deleted - gelöscht" sehen, können Sie eine Wiederherstellung probieren. Drive Rescue geht dann davon aus, daß die Datei nicht fragmentiert war.


Effektive Vorsorgemaßnahmen

Sie können die Chancen, Daten wiederherzustellen, erhöhen, wenn Sie einige Punkte beachten.

  1. Speichern Sie keine wichtigen Dateien im Wurzelverzeichnis ab.
    Dateien, die im Wurzelverzeichnis (root) abgespeichert werden, sind empfänglicher für einen Verlust durch Quick Formatierungen, weil dann Ordnereinträge im Wurzelverzeichnis abgelegt werden.
    Vermeiden Sie, Dateien direkt im Wurzelverzeichnis abzuspeichern, da die Datei verschwindet, wenn     der Verzeichnisentrag beschädigt ist. Im Notfall kann man Daten sehr schnell wiederherstellen, wenn sie sich in einem Unterordner befindet.

  2. Defragmentieren Sie regelmäßig die Festplatte
    Daten werden in aufeinanderfolgenden Clustern abgespeichert, wenn genügend zusammenhängender freier Speicherplatz zur Verfügung steht. Wiederholte Lösch- und Schreiboperationen fragmentieren das Laufwerk.

    Ein Beispiel:

    (1) (2) (3) (4) (5) (6) (7) (8) - sollen 8 kleine Dateien darstellen

     (1) (2) (3) (4) (5) (6) (7) (8) - jetzt wurden Dateien (2), (4), (7) und (8) gelöscht

    (1) (9) (3) (9) (5) (6) (9) (9) - Datenträger ist fragmentiert, wenn eine größere Datei gespeichert wird

    Wenn Daten vom Datenträger gelöscht werden, können neue Daten den freien Platz einnehmen. Wenn aber die neuen Daten größer als die alten sind, werden die Daten nicht in einem zusammenhängenden Bereich abgelegt, sondern in Fragmenten.
    Beim Lesen von fragmentierten Daten muß der Lesekopf der Festplatte "springen" (d.h. der Kopf wandert zu der gesuchten Spur). Dadurch kann die Lesen- und Schreibgeschwindigkeit herabgesetzt sein.
    Um den Lese-/Schreibvorgang wieder effizienter zu machen, ist es notwendig die fragmentierte Festplatte zu reorganisieren. Nach einer Defragmentierung sind die Daten wieder in sequentieller Reihenfolge und sehen dann so aus:

    (1) (9) (9) (9) (9) (3) (5) (6) - nachdem das Laufwerk defragmentiert wurde

    Eine gewöhnlich defragmentierte Festplatte wird die Effizienz einer Datenrettung verschlechtern, wenn z.B. der FAT durch ein QuickFormat oder einen Virus überschrieben wurde. Es ist dann notwendig genau zu analysieren, wie eine Datei über einen Datenträger verstreut liegt. Wenn aber zusammenhängende Daten vorliegen, ist eine Datenrettung anhand der Informationen über seine Position und Größe sehr schnell möglich.

    Wichtig: Ein Defragmentiertes Laufwerk wird, nach einer versehentlichen Löschung von Daten, die Wahrscheinlichkeit der Datenrettung sehr stark erhöhen, weil die Daten ab dem Cluster gespeichert sind, wo Ihre Daten beginnen.

  3. Speichern Sie keine wichtigen Daten auf Laufwerken mit geringer Kapazität
    Die Wahrscheinlichkeit der Wiederherstellung wird geringer, je kleiner die Speicherkapazität ist. Wichtige Daten sollten Sie auf einem freien Laufwerk sichern. Je kleiner die Kapazität ist, desto größer ist das Risiko einer Fragmentierung.

  4. Defragmentieren Sie Ihre Diskette, nachdem Daten auf dieser gespeichert wurden
    Disketten sind mit sehr hoher Wahrscheinlichkeit fragmentiert. Daher ist es ratsam bei wichtigen Daten, die Dateien in mehrere Verzeichnisse zu verteilen und dann die Diskette zu defragmentieren.

  5. Verwenden Sie kein Laufwerk, welches Sie zur Datenrettung benötigen.
    Installieren Sie keine Recovery Software auf einer Festplatte, welche Daten für Ihre Datenrettung enthält. Es könnten ansonsten Daten überschrieben werden und der Erfolg auf eine Datenrettung wird geringer. Vermeiden Sie jede Arbeit mit diesem Laufwerk und Speichern Sie dort keine Dateien. Verwenden Sie keine gewöhnlichen Programm, eingeschlossen den Windows Explorer, um nicht wichtige gelöschte Daten zu überschreiben.
    Für die Datenrettung sollten Sie ein zweites Laufwerk verwenden.